PostgreSQL La base de donnees la plus sophistiquee au monde.

Forums PostgreSQL.fr

Le forum officiel de la communauté francophone de PostgreSQL

Vous n'êtes pas identifié(e).

#1 05/08/2019 08:19:54

tholot
Membre

Impossibe d'appliquer le patch 9.6.14 sur ubuntu 14.04

Bonjour,

j'ai plusieurs serveurs postgres dont un ubuntu 14 avec postgres 9.6 dessus.

Jusqu'a présent tous les patchs sont passés sans soucis.

a l'heure actuelle celui-ci est en 9.6.13

commande  : pg_restore -V

reponse : pg_restore (PostgreSQL) 9.6.13

hors lorsque je lance un apt-get install postgresql-9.6

> sudo apt-get install postgresql-9.6
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
postgresql-9.6 est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 9 non mis à jour.

l'instance me répond que je dispose déjà de la version la plus à jour.

Pour contrer cette difficulté j'ai déjà :

1) redémarrer le serveur
2) mis à jour apt avec sudo apt-get update
3) verifiez la présence de l'appel à l'url

deb http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main

dans /etc/apt/sources.liste.d.

Je séche un peu sur ce qui ne va pas. des idées?

D'avance merci

Hors ligne

#2 05/08/2019 09:00:47

tholot
Membre

Re : Impossibe d'appliquer le patch 9.6.14 sur ubuntu 14.04

Petit complémént :

sur un ubuntu 14.04 également et sur le même réseau j'ai la même difficulté avec la mise à jour en postgresql 10.9 d'un autre serveur qui reste obstinément en 10.8 en spécifiant que c'est la version la plus à jour?

l'apt-get update atteint bien le dépot :

Atteint http://apt.postgresql.org trusty-pgdg/main amd64 Packages

?

Hors ligne

#3 07/08/2019 17:40:05

dverite
Membre

Re : Impossibe d'appliquer le patch 9.6.14 sur ubuntu 14.04

Ubuntu 14.04 a une durée de vie de cinq ans, elle est sortie en avril 2014, donc plus de maintenance depuis avril 2019.
Je pense que c'est pour ça que les mises à jour PostgreSQL post-avril 2019 ne sont pas disponibles en paquets.

Hors ligne

Pied de page des forums